$re = '/^((?!\.)[\w\-_.]*[^.])(@\w+)(\.\w+(\.\w+)?[^.\W])$/m';
$str = 'lama.loca.loca123@inca.com
pio_pio@factory.com
carnival666@hellmail.com
la-lalai@gmail.com
//INVALID EMAILS
//spaces at start
testmail@mail.com
//start with points
.testmail@mail.com
//finish with points
testmail@mail.com.
//spaces into the string
testm ail@mail.com
//Start/finish with any not number|letter char
testmail@mail.com.de
testmail@mail.de.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);