const regex = new RegExp('{[^}]*}', 'g')
const str = `{fefeef}this{feofeow}.4849`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);