$re = '/^[+-]?(?:\d+(?:\.\d+)?|\.\d+)$/m';
$str = '0.00000
0.00
-100
+100
-100.1
+100.1
.000
.1
3.
4.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);