// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-]?(?:\d+(?:\.\d+)?|\.\d+)$").unwrap();
let string = "0.00000
0.00
-100
+100
-100.1
+100.1
.000
.1
3.
4.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}