re = /[2](?=[0-3])\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s/
str = '19h32min16s
39h32min16s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end