import Foundation
let pattern = #"[2](?=[0-3])\dh|[0-1][0-9]h[0-5][0-9]min[0-5][0-9]s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
19h32min16s
39h32min16s
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)