import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\\"line\\\":\\\"(?<time>.+)\\|(?<log_level>.+)\\|(?<Controller>.+)\\|(?<Message>.+\\}|.+?)\\\"";
final String string = "{\"line\":\"18:48:17.990|INFO|PController|Plex event is media.pause}\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}\n\n"
+ "{\"line\":\"22:38:47.839|INFO|PController|{\\\"Id\\\":\\\"SMf1bc2466b1\\\",\\\"ErrorMessages\\\":null}\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}\n\n"
+ "{\"line\":\"22:38:47.839|INFO|PController|This is another test\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}\n\n"
+ "{\"line\":\"18:56:37.212|INFO|PController|media.stop\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}