// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\{\"line\":\"(?<time>.+)\|(?<log_level>.+)\|(?<Controller>.+)\|(?<Message>.+\}|.+?)\""#).unwrap();
let string = "{\"line\":\"18:48:17.990|INFO|PController|Plex event is media.pause}\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}
{\"line\":\"22:38:47.839|INFO|PController|{\\\"Id\\\":\\\"SMf1bc2466b1\\\",\\\"ErrorMessages\\\":null}\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}
{\"line\":\"22:38:47.839|INFO|PController|This is another test\",\"source\":\"stdout\",\"tag\":\"b5fcd8b8b5a4\"}
{\"line\":\"18:56:37.212|INFO|PController|media.stop\",\"source\":\"stdout\",\"tag\":\"4e263fa2001d\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}