package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0+`)
var str = `00AX
0000AK0
000CiaoAndrea `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}