re = /^((\()(?1)?(\))(?1)?)$/m
str = '//SHOULD
()
(())
((()))
()()
(())()
()()()
()()()()()
(((())))
()((()))
()()()()((()))(())((()))(((((((())))))))
//NOT
(
)
)(
))((
)()(
(()
))
())
(()
()()())
()())
)))))))))
((((((((
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end