re = /<a.*?href\s*=\s*(([\"\']).*?)\2.*?>.*?<\/a>/m
str = '<a style = "display: block;" href = "website.com">something here</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end