import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([\\d]{5})-([\\d]{7})-([\\d]{1}))|(([\\d]{5})([\\d]{7})([\\d]{1}))|(([\\d]{5}) ([\\d]{7}) ([\\d]{1}))$";
final String string = "// Allow these: \n"
+ "1234512345671\n"
+ "12345-1234567-1\n\n"
+ "// Don't Allow\n"
+ "12345 1234567-1\n"
+ "12345-1234567 1\n"
+ "12345123456718\n"
+ "12345-1234567-71\n"
+ "12345-12345678-1\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}