$re = '/\d+(?:(?:\s?[a-zA-Z]+)+(?:,|\s)+)+(?:[A-Za-z][A-Ha-hK-Yk-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})/ms';
$str = 'Hi Alice
I hope you\'re well. This is my address:
1 Test Street
Test Town,
AA1 1AA
Please get in touch soon. I have another address: 32 Island Road, Placington, AA2 2AA
Kind regards
Dan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);