package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^s3://([^/]+)/(.*)`)
var str = `s3://dev-datalake-cluster-bucket-q37evqefmksl/raw/wfm/users.11315`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}