$re = '/^s3://([^/]+)/(.*)/';
$str = 's3://dev-datalake-cluster-bucket-q37evqefmksl/raw/wfm/users.11315';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);