// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^s3://([^/]+)/(.*)").unwrap();
let string = "s3://dev-datalake-cluster-bucket-q37evqefmksl/raw/wfm/users.11315";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}