$re = '/.*([1-9][2-9]\d)$/';
$str = '-222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);