#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$"
Local $sString = "-1000" & @CRLF & _
"-200" & @CRLF & _
"-150" & @CRLF & _
"-1" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"12u" & @CRLF & _
"119" & @CRLF & _
"120" & @CRLF & _
"121" & @CRLF & _
"200" & @CRLF & _
"315" & @CRLF & _
"450" & @CRLF & _
"1000" & @CRLF & _
"1300" & @CRLF & _
"2300" & @CRLF & _
"6544" & @CRLF & _
"32165465465321312"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")