const regex = /^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?(?:[1-9][2-9]\\d|[2-9]\\d\\d|[1-9]\\d{3,}))$', 'gm')
const str = `-1000
-200
-150
-1
0
1
12u
119
120
121
200
315
450
1000
1300
2300
6544
32165465465321312`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}