use strict;
my $str = '-1000
-200
-150
-1
0
1
12u
119
120
121
200
315
450
1000
1300
2300
6544
32165465465321312';
my $regex = qr/^(-?(?:[1-9][2-9]\d|[2-9]\d\d|[1-9]\d{3,}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}