use strict;
my $str = '1.20.0
1.20.0rc0
1.20.0.dev0
1.24.0-git12345678-md5FFFFFFFFFFF
1.24.0+git12345678';
my $regex = qr/^(\d+)\.(\d+)\.(\d+)(rc\d+|\.dev\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}