using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(-)?(\d+)?(\s)?kg:\d+\.\d{2}";
string input = @"2 kg:0.352-10 kg:0.8010-50 kg:1.0050-200 kg:10.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}