#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<!,)\s(?=de\s\d{1,2}\sde\s[a-zç]+\sde\s\d{4})"
Local $sString = "DECRETO Nº 76.326 DE 23 DE SETEMBRO DE 1975." & @CRLF & _
"DECRETO Nº 76.326, DE 23 DE SETEMBRO DE 1975." & @CRLF & _
"DECRETO-LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975." & @CRLF & _
"LEI Nº 76.326 DE 23 DE MARÇO DE 1975." & @CRLF & _
"Decreto Nº 76.326 DE 23 DE SETEMBRO DE 1975" & @CRLF & _
"Decreto Nº 76.326 de 23 DE Setembro de 1975." & @CRLF & _
"DECRETO - LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975." & @CRLF & _
"DECRETO- LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975." & @CRLF & _
"DECRETO -LEI Nº 76.326 DE 23 DE SETEMBRO DE 1975."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)