$re = '/^Zelle.*Stephen Smith$/m';
$str = 'Zelle Transfer Conf# 0gdrc1050;, Stephen Smith';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);