const regex = /^.+\/p-\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+\\\/p-\\d+$', 'gm')
const str = `arthi/p-884294
http://www.camicado.com.br/jogo-panelas-ana-maria-braga-revestimento-ceramico-5-pecas-vermelho/p-775584`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}