using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z]:\\((?:.*?\\)*).*";
string input = @"C:\Users\username\Documents\Files\aa.xx
C:\Users\username\chocolate\Files\aa.xx
C:\Users\username\Documents\Files\aa.xx
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}