package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<start>[^0-9]+)?(?:[0-9]+)?(?<end>[^0-9]+)$`)
var str = `/dev/server/3/statistics
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}