#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\S+)"
Local $sString = "3345 Michelson Drive, Suite 400, Irvine, CA 92612" & @CRLF & _
"12303 Airport Way, Suite 250, Broomfield, CO 80021" & @CRLF & _
"Two North Riverside Plaza, Suite 1430, Chicago, IL 60606" & @CRLF & _
"#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145" & @CRLF & _
"!Variety Coffe Cup, Potraiture 247, Mars, MS 88888" & @CRLF & _
".* Everywhere, Nowhere 123, Eternity, ET 12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")