#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\/([^/]+)\/[^/]+"
Local $sString = "/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")