$re = '/.*\/([^/]+)\/[^/]+/';
$str = '/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);