import Foundation
let pattern = #".*\/([^/]+)\/[^/]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/9c2a1079-35f0-4298-9eb3-7f63903f2ae1/resourceGroups/cte/perarEssaPalavra/providers"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}