#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "0*(?:[1-9]\d*(?:\.\d*)?|\.0*[1-9]\d*)"
Local $sString = "2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2." & @CRLF & _
"BUT NOT " & @CRLF & _
"0, 0.0, 00.0, 0.00, 00.00, .0, 0."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")