const regex = /0*(?:[1-9]\d*(?:\.\d*)?|\.0*[1-9]\d*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(?:[1-9]\\d*(?:\\.\\d*)?|\\.0*[1-9]\\d*)', 'g')
const str = `2.5, 0.12 ,222.22, 00.98, 0.23, 12.00, 0.004, .0012, 1.0, 2.
BUT NOT
0, 0.0, 00.0, 0.00, 00.00, .0, 0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}