Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<!A\()\bHello\b
/
gm
Input 1
1
New
Hello hi A(Hello) Hello!
Substitution
A($&)
Hello hi A(Hello) Hello!