use strict;
my $str = 'Hello hi A(Hello) Hello!';
my $regex = qr/(?<!A\()\bHello\b/mp;
my $subst = 'A($&)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";