import re
regex = re.compile(r"(?<!A\()\bHello\b", flags=re.MULTILINE)
test_str = "Hello hi A(Hello) Hello!"
subst = "A($&)"
result = regex.sub(subst, test_str)
if result:
print(result)