import Foundation
let pattern = #"(?<!A\()\bHello\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello hi A(Hello) Hello!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"A($&)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)