using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http|https):\/\/([^\[\/:]+|\[[a-fA-F0-9:]+\])(?::\d+)?\/?(.*)";
string input = @"http://spinetix.com:80/test/ok?q=1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}