re = /^(.*?)(\/target-)(.*?)(\.md)$/i
str = '/dir1/dir2/dir3/dir4/../dir7/dir8/dir9/target-.a-word1-word2-alphanumberic1-alphanumberic2.md'
# Print the match result
str.match(re) do |match|
puts match.to_s
end