import re
regex = re.compile(r"[A|a]nother (one|two|three)|[A|a]nother \d+|[E|e]xtra (one|two|three|four|five)|[E|e]xtra \d+|(one|two|three|four) more", flags=re.MULTILINE)
test_str = ("another one\n"
"another blah\n"
"another\n"
"another two\n"
"Another one\n"
"another 1\n"
"another 10\n"
"extra one\n"
"Extra one\n"
"extra two\n"
"extra\n"
"extra blah\n"
"extra three\n"
"extra 1\n"
"extra 2\n"
"one more\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")