#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)vn (-?[0-9. ]+){3}|v (-?[0-9. ]+){3}|f ([0-9. \/]+){3}"
Local $sString = "v -1 1 0" & @CRLF & _
"v -1 0 0" & @CRLF & _
"v 1 0 0" & @CRLF & _
"v 1 1 0" & @CRLF & _
"v 0 2 0" & @CRLF & _
"" & @CRLF & _
"f 1 2 3 4 5" & @CRLF & _
"" & @CRLF & _
"vn 0 0 1" & @CRLF & _
"vn 0.707 0 -0.707" & @CRLF & _
"vn 1 2 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")