$re = '/(?:(?!ENSG).)*(ENSG[0-9]+[^|]).*/m';
$str = 'ENSG00032411234|ENSG000865852297';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);