import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b\\.\\b(\\d{1,2}|1\\d{2}|2[0-4]\\d|25[0-5])\\b";
final String string = "invalidos:\n\n"
+ "192.268.0.1\n"
+ "1.333.1.1\n"
+ "192.168.0.256\n"
+ "256.256.256.256\n\n"
+ "validos:\n"
+ "192.168.0.1\n"
+ "127.0.0.1\n"
+ "10.0.0.255\n"
+ "10.11.12.0\n"
+ "255.255.255.255\n"
+ "0.0.0.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}