using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Total\r?\n)(.+)\s+\d+\s+\d+\s+([A-z]{3})";
string input = @"Item Description Quantity Price Per Total
Various paper supplies 1 269033 USD 269033 USD
Subtotal: 224194 USD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}