import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(?: {4})*) {4}";
final String string = "\n"
+ " a = 1\n"
+ " aaaaaaa = 2\n"
+ " aaaa = 3\n"
+ " a = 1\n"
+ " aaaaaaa = 2\n"
+ " aaaa = 3";
final String subst = "\\t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}