re = /(?<=^(?: {4})*) {4}/m
str = '
a = 1
aaaaaaa = 2
aaaa = 3
a = 1
aaaaaaa = 2
aaaa = 3'
subst = '\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result