package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(?<token>\w*)(:(?<format>.*?))?}`)
var str = `{ "numericField": "{age:%d}", "strField": "{name}", "datefield": "{dateofbith:yyyy-MM-dd}" }";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}