re = /{(?<token>\w*)(:(?<format>.*?))?}/
str = '{ "numericField": "{age:%d}", "strField": "{name}", "datefield": "{dateofbith:yyyy-MM-dd}" }";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end