using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9-]+)(\.md)";
string substitution = @"2022-01-01-$1$2";
string input = @"./src/content/posts/commit-without-file-changes-in-git.md";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}