package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z0-9-]+)(\.md)`)
var str = `./src/content/posts/commit-without-file-changes-in-git.md`
var substitution = "2022-01-01-$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}